RESOLVED - Staking enabled error

Expected behavior


When unticking the box enable staking under settings, the small green box in the top right corner should not show staking enabled

Actual behavior

Well it still does

Operating system


  • [ x] Mac OSX
  • [ ] Windows 10
  • [ ] Windows 8/8.1
  • [ ] Linux Ubuntu 16.04
  • [ ] Linux Ubuntu 18.04
  • [ ] Linux Debian
  • [ ] Other UNIX/Linux distribution

Detailed reproduction steps

untick “enable staking” under settings. Restart wallet. Gren box in the top corner still shoves “staking enabled”

The new icon goes based on whether or not staking status = true. How long did you give it to turn false after disabling staking?

I think it has been half an hour now. But I would think it would be the other way around since I restarted the wallet. The Box in settings should be checked before showing staking enabled, right?

Yes but if you uncheck it it could take a while for it to turn false. Anyway to be honest with you I’m not even sure that box does anything anymore…might need to look into that.

It is still nice to have the ability to turn staking off. My suggestion is that the box function is changed to disable staking instead of enable staking, since most user would want that. But of course the box has to be part of the parameters checked

I agree with you.

Replaced by slider in new builds