RESOLVED - Masternode changed to "Expired" Stopped Getting Rewards - Had to reissue "startmasternode"


(JJMacau) #1

Expected behavior

Gold masternode installed on Vultr VPS was active and working, paying rewards until it changed to “expired”, it does still appear in Diviscan.io, I had to issue "startmasternode command again.

Actual behavior

Masternode installed on Vultr VPS, was paying rewards for one day, then stopped. listrmasternodes command now says “expired” and has stopped paying rewards for 24 hours. I issued the Startmasternodes command and it now comes back as enabled.

Operating system


  • [ ] Mac OSX
  • [x ] Windows 10
  • [ ] Windows 8/8.1
  • [ ] Linux Ubuntu 16.04
  • [x ] Linux Ubuntu 18.04
  • [ ] Linux Debian
  • [ ] Other UNIX/Linux distribution

Detailed reproduction steps


When I checked the masternode it was expired:

Listermasternodes DTag7ZHZUNUTsuvpGJW7mYgAjQRXfAvzwF

[
{
“activetime”: 199565,
“addr”: “DTag7ZHZUNUTsuvpGJW7mYgAjQRXfAvzwF”,
“lastpaid”: 0,
“lastseen”: 1539092423,
“network”: “ipv4”,
“outidx”: 0,
“status”: “EXPIRED”,
“tier”: “GOLD”,
“txhash”: “5a6165f715574a20fa04450cfe9e127ea84d0b5054b99783a914681917c4a785”,
“version”: 70915
}
]

Ran startmastenode command and it is now back enabled:

listmasternodes
23:54:26
[
{
“activetime”: 0,
“addr”: “DTag7ZHZUNUTsuvpGJW7mYgAjQRXfAvzwF”,
“lastpaid”: 0,
“lastseen”: 1539100432,
“network”: “ipv4”,
“outidx”: 0,
“status”: “ENABLED”,
“tier”: “GOLD”,
“txhash”: “5a6165f715574a20fa04450cfe9e127ea84d0b5054b99783a914681917c4a785”,
“version”: 70915
}
]


(~ Node of the Realm ~) #2

Has this happened again JJ since you restarted the MN?


(JJMacau) #3

No, just that one time.


(OriZ) #4