RESOLVED - Help needed with old wallet.dat recovery without seed phrase


#1

Hello,
I participated in Divi ICO, passed KYC, and only yesterday decided to try to do DIVX -> DIVI swap and set up MOCCI masternode. Swap went fine but I faced issues with setting up masternode as this process stuck 2 times (at 2 and 7 or 8 steps). After 2nd stuck I exited my wallet and tried to open it once again but then v1.0.5 update popped up which I could not close and after this update I was redirected to new wallet where I could not find my DIVI coins. The issue is that I did not set up seed phrase in the old wallet as it was not written anywhere that it is necessary but I encrypted the old wallet (set up password), have old wallet’s address, and have its backups from AppData\Roaming\DIVI\backups, although I did not press backup button in the old wallet.

So I need help from Divi developers with the recovery of my old wallet from old wallet.dat file without seed phrase. With @TheVoice and @oriz123 on Divi Support channel in Telegram we tried everything: copy oldest wallet.dat backup file from backups folder to the main DIVI folder (then wallet is stuck at “Loading” phase), clean wallet’s install, turn off firewall and so on. I can provide you all the needed information from which you could trace all the transactions to me, just tell me what I need to do next.


(OriZ) #2

When trying to reinstall, are you sure you removed all the old stuff?

So you have your whole DIVI dir backed up somewhere on your computer right? We used the oldest backup file before. Lets try again. In c:\users\youruser\appdata\roaming…completely remove DIVI, and divi desktop…then in c:\program files completely remove divi desktop, this includes the recycle bin.

Then install version 1.0.5, and then go into your backed up DIVI folder, and into the backup folder within the divi folder, and we’re going to try a different backup file now than before, pick the next in line(second oldest)…copy it over to your new DIVI folder that you just installed with v 1.0.5, and rename it wallet.dat and try to start it again. Make sure you have no old processes running in the background, ideally completely remove any av/firewall and restart your computer before trying to start the program.


#3

I tried this yesterday and now I have just tried it once again but the result is the same - wallet is stuck at “Loading” phase. It get’s a bit better when I try to install v1.0.0, then wallet loads up until, say, 50% with old wallet.dat file but then it is overrun by v1.0.5 update and then it’s the end of the party.


(TheVoice) #4

we did everything -resync,

Backup and Clean Install

Restore an old wallet from backups

@AndFomo can you restart BUT before that run task manager and watch for divid white you restart.

Tell us what you see


(OriZ) #5

Did we/you try to have him start the new version with a brand new wallet created and see if it loads then, to verify if the issue is with the actual wallet?


#6

There is no Divi in the task manager.


#7

Yes, brand new wallet loads and syncs perfectly fine.


(TheVoice) #8

Ok so In the DIVI folder in appdata/roaming

Rename wallet.dat to wallet.old and then restart watch for divid in task manager


#9

This does not work, I already tried it, or you want me to start wallet without wallet.dat file?


(TheVoice) #10

Yes rename the existing wallet - so there will be no file that says wallet.dat in that folder - name the existing to wallet.old

Restart and watch task manager for DIVID


#11

Surprisingly the wallet loaded, synced, and was in the task manager without wallet.dat file but, again, new wallet was presented to me.


#12

So I guess only Divi developers can retrieve my old wallet from my backup files, @nicksaponaro and @geoff can you help me here? It seems that I could do it myself with v1.0.0 wallet because there my old wallet.dat at least starts loading but loading is interrupted with v1.0.5 update and then I am presented with a new wallet.


(TheVoice) #13

I needed to make sure divid was running.

Shutdown Divi desktop and then delete out the new wallet.dat and then rename your wallet.bu back to wallet.dat.

Start the wallet.


#14

Same outcome, if I insert old wallet.dat file, then wallet is stuck at “Loading”, and if do not insert it, then I am presented with brand new wallet.


#15

The same happens to me. I got to the problem differently, but the consequence is the same. My wallet.dat and my oldest backup do not return my wallet. I also keep loading with my original wallet.dat, or create a new account with the different support instructions.
With the help of the support programmers we reached a dead end. We need the help of expert programmers like Yura with the problem of: “signing transaction failed”.
So we will can confirm the solution or if you are totally stuck, to look for other solutions and move forward . I’ve been waiting since September 30, and I have patience, but it’s time to level up this problem.
I am very understandable with the work that the team is doing, but the anxiety that I am experiencing is only known to me. I hope you understand me.


#16

@yuraolex please take a look at this issue, it’s been already few restless weeks for me…


(OriZ) #17

Ok so you still have those backup files we tried right? get your oldest wallet.dat again, download the new version that was released today, and use it in there…let me know if that works.

Something else to try: with the gui closed, open a command prompt window(you can do this by typing cmd in the start/search menu) and type ‘cd c:\users\yourusername\appdata\roaming\divi desktop\divid\unpacked\divi_win_64’ and hit enter

then type ‘divid’ and again hit enter.

then type ‘divi-cli walletpassphrase yourpassword 0’

then type ‘divi-cli getinfo’ and let me know what you see.


#18

@oriz123 this also does not work:

C:\Users\XXXXX>cd c:\users\XXXXX\appdata\roaming\divi desktop\divid\unpacked\divi_win_64

c:\Users\XXXXX\AppData\Roaming\Divi Desktop\divid\unpacked\divi_win_64>divid
Error: wallet.dat corrupt, salvage failed

c:\Users\XXXXX\AppData\Roaming\Divi Desktop\divid\unpacked\divi_win_64>divi-cli walletpassphrase XXXXX 0
error: couldn’t connect to server

c:\Users\XXXXX\AppData\Roaming\Divi Desktop\divid\unpacked\divi_win_64>divi-cli getinfo
error: couldn’t connect to server


(OriZ) #19

Ok thanks, that’s what I needed to know. So your wallet.dat is corrupted, please see this thread “Signing Transaction Failed” Wallet Repair with Yuri and ask for them to give you permission to send your file to yuri. Feel free to provide some background and link to this thread.


"Signing Transaction Failed" Wallet Repair with Yuri
(OriZ) #20