RESOLVED - Deploy MN: "Signing transaction failed"


(Yurraolex) #21

can you call validateaddress on address that you own? and show result here?


#22

I’ve got a similar problem, and have run validateaddress, and have the results. Some fields look like they might not be safe to post on a forum for security reasons. Are there any parts of the result we should black out/omit before posting?


(Yurraolex) #23

I am interested mostly in hdkeypath


#24

My issue triggered when trying to create a MOCCI, so there are two:

Masternode:
“address”: “DGXdtWhe8FcTTjVtGt1AUGuu6KXZVJrpKm”,
“hdkeypath”: “m/44’/301’/0’/0/5”,

Wallet Holding Remaining Funds:
“address”: “DBQak6baXcmdDVU2eZ8V4ifGaHQh2cxbyG”,
“hdkeypath”: “m/44’/301’/0’/1/0”,

When I restore from Seed on another computer, these addresses do not get included. Running validateaddress on that machine gives ismine: false in both cases.


(Lanfear) #25

So I´m having the same issue. for me it returns “hdkeypath”: “m/44’/301’/0’/0/0” for the address in question


#26

Mine is “hdkeypath”: “m/44’/301’/0’/0/0”,


(Johnny401View) #27

Mine does not have the problem and it says:

“hdkeypath”: “m/44’/301’/0’/0/3”,


(sai) #28

“hdkeypath”: “m/44’/301’/0’/0/0”


(Yurraolex) #29

Ok, that’s enough. Thanks


#31

@yuraolex I have checked my Divi folders and I did have a walllet.xxx.bak backup file as well as a folder with back ups.

I have tried replacing the current wallet.dat with the .bak file, but it contained a different address and zero Divi as well as a different recovery phrase

Then I tried the first 3 backups from the backup folder, of which only one showed me the correct amount of Divi as well as the original/current recovery phrase, but also the same signing problem.

Strangely enough the other 2 backups I have tried, all have zero balance, but also all of them had different (from eachother!) recovery phrases.

So for now I have at least 4 different recovery phrases for the same (?) wallet/installation, but only one is the same as the current phrase and that one has the Divi, which cannot be spent, on MOcci nor on any other transaction.


(Johnny401View) #32

Everyone is working as hard as possible (including all the many volunteers) to resolve issues as quick as possible.


(TomBowyer) #34

You may want to break up your text, make it more concise and to the point, you may get a better response.


#35

sorry, I am new and I am very nervous with the loss of my account and my coins. This is not where I had to write it, I have already opened a thread. Sorry for everyone. You can erase it, it’s in the wrong place, I understand it.


(henning søgaard) #36

what is the status from dev on the problem ?


(Lanfear) #37

Yeah I´m also hoping for a quick update, with the amount of funds I have stuck and current inflation levels this is getting quite costly…


#38

A full day without any reaction from the devs, no request for more info/details and no update on what is happening to help the many that are stuck in limbo with their hard-earned Divi. Please be more communicative, we are all afraid we lost our investment and are missing out on expected income.


(Yurraolex) #39

I am working on that issue, but I have no way to reproduce it on my side. If someone would like to share his wallet.dat with me that has signing issue it would be great help .


(~ Node of the Realm ~) #40

@yuraolex I can send you a wallet.dat with 2Divi locked in it with TX Signing failed. However I created mine by sending Divi from the current Chain to an old wallet.dat from a beta chain that I synced up with the current chain. The wallet.dat synced (obviously with no beta balance in it) . I then sent it 2 DIvi to see if it could revcieve. It did recieve without issue. But the 2 divi it received are locked with signing tx failed issue… It may not be the exact same issue the others have. Technically I have an old build wallet synced to this chain that can accept divi, but not send them out. It is the only way I have been able to reproduce the issue… by sending divi to a pre-launch build wallet.dat (previously synced to a different chain) that is now using the latest 1.0.0 Cli & Desktop


(Yurraolex) #41

Well, I know exactly what is your problem, I can fix that in code, but it doesn’t make sense at all. This isn’t even a fix, more like a hack, because you have mixed some old wallet.dat with new chain.


(Peter) #42

I could share mine but I’m not sure that my problem is exactly the same as other people have. I get the signing transaction error message at step 2 when trying to setup a masternode but I also can’t move funds out of the wallet and my second redeem transaction doesn’t have a transaction ID even though I’m supposed to have received it according to my wallet except when doing a wallet restore where that specific transaction is missing but all others are shown…