RESOLVED - Deploy MN: "Signing transaction failed"


(Nicolas Schläpfer) #1

Hi

I downloaded the divi wallet a while ago. After launch i deleted the wallet and all the AppDatas a could find.

Then I downloaded the new wallet and everything synced perfectly and i received my divi coins.

When I want to deploy a MN, it shows that the “Signing transaction failed”. I would have more than enough Divi to deploy the MN. Even a copper doesn’t work.

One mistake I made, was that I did not add Divi Desktop to the windows defender. Now I’ve added it and it still does not work.

Did I do something wrong?

Could someone help me please?

Thank you in advance.
Nicolas

Expected behavior

deploy a MN

Actual behavior

“Signing transaction failed”

Operating system


  • [ ] Mac OSX
  • [x ] Windows 10
  • [ ] Windows 8/8.1
  • [ ] Linux Ubuntu 16.04
  • [ ] Linux Ubuntu 18.04
  • [ ] Linux Debian
  • [ ] Other UNIX/Linux distribution

(Nicolas Schläpfer) #2


#3

These’s a number of us over on

With the same issue. I think the devs are a bit stumped, so it might help to add your voice over on that discussion so that they have fewer threads to manage.


(Nicolas Schläpfer) #4

Now it works :slight_smile:

Perhaps I can deliver you the explanation. As I downloaded the wallet I wrote down the backup seed. A little later I had to write down the Seed again. But this time it was a different one.

I uninstalled and deleted everything. After installing the new wallet again and recover it with the second seed, all my coins were gone. Afterwards I recovered the wallet with the first Seed and then my coins were here again.

Afterwards it was no problem to deploy the MN.

Perhaps this will help the DEVS :slight_smile:

Best regards and sorry for my English.
Nicolas


#5

I think we may have been having different issues, but I’m glad yours got fixed. Happy staking!


(OriZ) #6

odd, backup phrase should always be the same. Regardless of the reason this thread was opened, this in and of itself should be looked into.


#7

Yes this signing transaction failed is has happened to my friend also. He also told me that the was asked by a password twice and got a new backup phrase.

He got the “signing transaction failure” and tried to create a copy of the wallet on another machine with the back-up phrase. On the second PC he can only see DIVI I have send to his account for a joined masternode - he can’t see his own DIVI from redemption.

On PC1 he can see the total amount but they are locked with “signing transaction failure”.

Could the failure have something to do with wallet asking for new password a second way around and creating new back-up phrases?

Furthermore he has tried to clean the PC and reinstall wallet and copy the wallet.dat from PC1 and it seems the failure follows the wallet.dat file.


(Johnny401View) #8

Has anyone tried to dumpprivatekey? Backup existing Divi folder, reinstall and reimport the keys?


(sai) #9

I have, I get the same error wherever the wallet goes.


(Johnny401View) #10

Thank you for the check.


(Johnny401View) #11

@yuraolex ^^^


(Johnny401View) #12

Here’s what I’m thinking:

It doesn’t solve the root issue, but might be a way to move funds off a wallet that gets the signing transaction failed.


#13

If you’re suggesting that we use the CLI to force a transaction through, that seems like a reasonable test. Can someone provide the steps for this in Divi?


(Peter) #14

I second that. I can move money to and from my wallet, just not below the value of my second redeem. If they can be moved from the wallet with cli the problem would be solved.


(sai) #15

I tried this on the windows wallet but I get red text and no error. I tried several formats, it would be helpful to know the format that works with Divi. If I use single quotes around the parameters I get this error; “expected type array, got string” so it is accepting the input without single quotes but it doesn’t display an error if it’s an incorrect format or if the values are incorrect somehow.

createrawtransaction [{“txid”:“id here”,“vout”:1}] {“receiving address”:0.025,“sending address”:0.0245} ;returns red text

createrawtransaction [{“txid”:“id here”,“vout”:0}] {“receiving address”:0.025} ;also returns red text

createrawtransaction ‘[{“txid” : “id here”, “vout” : 0}]’ ‘{“receiving address”: 0.025, “sending address”: 0.0245}’ ;returns “expected type array, got str”


(sai) #16

I’ve tried creating a raw transaction using the cli wallet on ubuntu and it outputs a hex string;
./divi-cli createrawtransaction “[{“txid”:“7b57f579cb559becacc0e1f89386f80820287e97463b6032fb0a6327b3e9a06f”,“vout”:0}]” “{“DD5dgh9syNJVLwqjVhrfa6Af8Lv8YpD6Ho”:0.01}”

but when I try signing it I get this;
./divi-cli signrawtransaction (long hex string here)
{
“hex” : “(long hex string here)”,
“complete” : false
}


(Johnny401View) #17

@nicksaponaro I thought this might help to relay back to the devs.


(TomBowyer) #18

When I get the signing transaction failed error after running ./divi-cli sendtoaddress D9fSJrRhVdyUFHuHeksDZkpDrKFDZKVeQs 1

The debug.log shows:
2018-10-02 21:35:16 keypool reserve 1002
2018-10-02 21:35:16 SendMoney() : Signing transaction failed
2018-10-02 21:35:16 keypool return 1002

Whats a keypool?


(Peter) #19

That looks like the same as I get when trying to setup a masternode. Probably also when trying to send divi.


(Yurraolex) #20

What did you do between writing down two seeds? I am trying to understand why you’ve seen two different seeds. Maybe you have encrypted your wallet?


RESOLVED - Cannot access funds after failing to create MOCCI