Desktop wallet cannot sync, keeps restarting daemon

Expected behavior

Wallet always synced when continuously online

Actual behavior

Wallet is 9.99% synced but never caught up. Daemon keeps restarting.

Operating system


  • [ ] Mac OSX
  • [ X ] Windows 10
  • [ ] Windows 8/8.1
  • [ ] Linux Ubuntu 16.04
  • [ ] Linux Ubuntu 18.04
  • [ ] Linux Debian
  • [ ] Other UNIX/Linux distribution

Detailed reproduction steps

Start wallet
Wait for it to sync

I have restarted the wallet and bootstrapped it (as suggested by the wallet itself). Still there are 80 blocks to sync even though it’s continually syncing, and estimated time left is infinite. Internet connection is functional.

I highly recommend joining our telegram as that is where you will usually find issues like this come up and be answered sooner. It appears like you are forked and on the wrong chain, what you need to do is actually disable primer. Follow these steps:

  1. Go into settings > maintenance > and uncheck automatic primer restore

  2. Do a process 3 but with a change.
    You must rename there existing divi.conf to divi.backup and import the divi.conf file attached to this post into the “DIVI” directory where you just applied the process 3.

Links for process 3 below

Windows Process 3
https://www.youtube.co/watch?v=mSiiKZPdYaM)

OSX Process 3

  1. Restart - However, make sure you do not accept “primer” restore. Let the wallet do a standard trustless long sync and all will be well.

Here is the link for the new file: https://easyupload.io/vjtch4

1 Like

Thanks - I’ve all of the above, and the wallet is syncing (618,000 blocks left).